7-5 括号匹配 (18分)

检查一段C语言代码的小括号( )、 中括号 [ ] 和大括号{ } 是否匹配。

输入格式:

在一行中输入一段C语言代码,长度不超过1000个字符(行末以换行符结束)。

输出格式:

第一行输出左括号的数量和右括号的数量,中间以一个空格间隔。
若括号是匹配的,在第二行打印YES,否则打印NO

输入样例1:

1
for(int i=0; i<v; i++){ visited[i] = 0; for(int j=0; j<v; j++) scanf("%d",&(g->Adj[i][j])); }

输出样例1:

1
2
8 8
YES

输入样例2:

1
for(int i=0; i<v; i++) a(i]=0;

输出样例2:

1
2
2 2
NO
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
#include <iostream>
#include <stack>

using namespace std;

bool is_left_kuohao(char ch)
{
return ch == '(' ch == '[' ch == '{';
}

bool is_right_kuohao(char ch)
{
return ch == ')' ch == ']' ch == '}';
}

bool match(char left, char right)
{
return (left == '(' && right == ')')
(left == '[' && right == ']')
(left == '{' && right == '}');
}

int main()
{
string line;
getline(cin, line);

int left_kuohao_count = 0;
int right_kuohao_count = 0;

for (int i = 0; i < line.length(); i++)
{
if (is_left_kuohao(line[i]))
left_kuohao_count += 1;
if (is_right_kuohao(line[i]))
right_kuohao_count += 1;
}

cout << left_kuohao_count << " "
<< right_kuohao_count << endl;

stack<char> left_kuohaos;

for (int i = 0; i < line.length(); i++)
{
if (is_left_kuohao(line[i]))
left_kuohaos.push(line[i]);
if (is_right_kuohao(line[i]))
{
if (!left_kuohaos.empty() && match(left_kuohaos.top(), line[i]))
left_kuohaos.pop();
else
{
cout << "NO" << endl;
return 0;
}
}
}
if (left_kuohaos.empty())
cout << "YES" << endl;
else
cout << "NO" << endl;

return 0;
}