7-5 求集合交集 (20分)

求整数集合A与整数集合B的交集。

输入格式:

输入有三行: 第一行是A和B的元素个数m和n; 第二行是集合A的m个元素; 第三行是集合A的n个元素。

输出格式:

输出交集的所有元素(按照在A集合出现的顺序输出,最后一个输出后面没有空格)。

输入样例:

在这里给出一组输入。例如:

1
2
3
3 4
10 9 2
9 10 8 0

输出样例:

在这里给出相应的输出。例如:

1
10 9
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include<stdio.h>
int main()
{
int a,b,alist[999],blist[999];
scanf("%d%d",&a,&b);
for(int i=0;i<a;i++){
scanf("%d",&alist[i]);
}
for(int j=0;j<b;j++){
scanf("%d",&blist[j]);
}
int clist[999]={0};
int q=0;
for(int k=0;k<a;k++){
int temp=alist[k];
for(int p=0;p<b;p++){
if(temp==blist[p]){
clist[q]=temp;
q++;
}
}
}
if (q>0){
for(int u=0;u<q-1;u++){
printf("%d ",clist[u]);
}
printf("%d",clist[q-1]);
return 0;} else{
return 0;
}
}